AGOT Overhaul v1.21 (w/ Valyrian Magic)

Browse, publish and discuss user made sub-mods here

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Mazetism » Tue Jun 28, 2016 16:39

Hi, I seem to get random crashes after so long

I look at the error log and I constantly see this

Spoiler: show
[virtualfilesystem.cpp:513]: Reached max depth when enumerating files recursive: i[persistent.cpp:37]: Error: "Malformed token: yes, near line: 18
" in file: "common/traits/dothraki_traits.txt" near line: 18
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 17
" in file: "common/traits/religion_traits.txt" near line: 17
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 79
" in file: "common/traits/religion_traits.txt" near line: 79
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 111
" in file: "common/traits/religion_traits.txt" near line: 111
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 133
" in file: "common/traits/religion_traits.txt" near line: 133
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 156
" in file: "common/traits/religion_traits.txt" near line: 156
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 3
" in file: "common/traits/valyrian_traits.txt" near line: 3
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 6
" in file: "common/traits/zz_new_traits.txt" near line: 6
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 25
" in file: "common/traits/zz_new_traits.txt" near line: 25
[persistent.cpp:37]: Error: "Malformed token: yes, near line: 1048
" in file: "common/traits/zz_new_traits.txt" near line: 1048
[persistent.cpp:37]: Error: "Unexpected token: fist_amount, near line: 1469
" in file: "common/retinue_subunits/00_retinue_subunits.txt" near line: 1469
[technology.cpp:756]: Missing Tech seed values:
[technology.cpp:759]: d_central_valyria
[technology.cpp:759]: d_valyrian_isles
[technology.cpp:759]: d_valyrian_mainland
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 28
" in file: "events/custom_prisoner_events.txt" near line: 28
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 41
" in file: "events/custom_prisoner_events.txt" near line: 41
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 127
" in file: "events/custom_prisoner_events.txt" near line: 127
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 269
" in file: "events/custom_prisoner_events.txt" near line: 269
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 286
" in file: "events/custom_prisoner_events.txt" near line: 286
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 429
" in file: "events/custom_prisoner_events.txt" near line: 429
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 446
" in file: "events/custom_prisoner_events.txt" near line: 446
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 588
" in file: "events/custom_prisoner_events.txt" near line: 588
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 605
" in file: "events/custom_prisoner_events.txt" near line: 605
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 747
" in file: "events/custom_prisoner_events.txt" near line: 747
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 764
" in file: "events/custom_prisoner_events.txt" near line: 764
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 906
" in file: "events/custom_prisoner_events.txt" near line: 906
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 923
" in file: "events/custom_prisoner_events.txt" near line: 923
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 1065
" in file: "events/custom_prisoner_events.txt" near line: 1065
[persistent.cpp:37]: Error: "Unexpected token: has_character_modifier, near line: 1471
" in file: "events/feast_events.txt" near line: 1471
[persistent.cpp:37]: Error: "Unexpected token: has_character_modifier, near line: 1996
" in file: "events/high_valyrian_events.txt" near line: 1996
[persistent.cpp:37]: Error: "Unexpected token: remove_claim, near line: 6229
" in file: "events/maintenance_events.txt" near line: 6229
[persistent.cpp:37]: Error: "Unexpected token: gfx, near line: 6
" in file: "events/steal_spouse_title_events.txt" near line: 6
[persistent.cpp:37]: Error: "Unexpected token: title, near line: 7
" in file: "history/wars/ACOK- Brotherhood of Banners.txt" near line: 7
[persistent.cpp:37]: Error: "Unexpected token: title, near line: 7
" in file: "history/wars/AFFC- Brotherhood of Banners.txt" near line: 7
[persistent.cpp:37]: Error: "Unexpected token: title, near line: 7
" in file: "history/wars/AFFC- Whitehills vs Forresters.txt" near line: 7
[pdx_backend.cpp:68]: PUST ERROR 1: Timeout was reached


This has never happened to me before upgrading to the new version. It's always the same problems and I see mainly valyrian issues so my thought its related to this submod. I did a couple tests deactivating the mod and never experienced a crash. Any idea what can be made to fix this? Great mod and thanks.
User avatar
Mazetism
 
Posts: 3
Joined: Tue Jun 28, 2016 15:24

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by GoTfanboy » Wed Jun 29, 2016 05:25

Did you keep colonize Valyria enabled, and only disable AGOT Overhaul? When you stopped getting crashes.

It sounds like you may not be using colonize Valyria.
“... a mind needs books as a sword needs a whetstone, if it is to keep its edge.”
User avatar
GoTfanboy
 
Posts: 88
Joined: Wed May 27, 2015 03:31

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by GoTfanboy » Wed Jun 29, 2016 05:28

Alayusas wrote:Ah, Hello, I've been really intrested in your submod and tried it including all the other requirements you've put up, but it keeps on crashing after a year, and I've never had that happen even in other playthroughs, I looked that it's said 2.5.2 specifically so I reverted to that aswell but still not working well, any ideas?


Unfortunately no. I only run this, colonize Valyria, and AGOT 1.2 on CK2 2.5.2.

I've never had a crash while playing.
“... a mind needs books as a sword needs a whetstone, if it is to keep its edge.”
User avatar
GoTfanboy
 
Posts: 88
Joined: Wed May 27, 2015 03:31

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Suntroll » Wed Jun 29, 2016 13:52

Is this mod compatible with Flamequeen's Ultimate Building Submod?
Suntroll
 
Posts: 4
Joined: Mon Dec 28, 2015 20:55

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Mazetism » Wed Jun 29, 2016 14:33

GoTfanboy wrote:Did you keep colonize Valyria enabled, and only disable AGOT Overhaul? When you stopped getting crashes.

It sounds like you may not be using colonize Valyria.



Oh no, I'm using Colonize Valyria. I found this mod through Colonize Valyria.
User avatar
Mazetism
 
Posts: 3
Joined: Tue Jun 28, 2016 15:24

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Aszrayel » Wed Jun 29, 2016 18:57

Mazetism wrote:
GoTfanboy wrote:Did you keep colonize Valyria enabled, and only disable AGOT Overhaul? When you stopped getting crashes.

It sounds like you may not be using colonize Valyria.



Oh no, I'm using Colonize Valyria. I found this mod through Colonize Valyria.


Are you running AGOT 2.5.2.2 like I am? Same thing happens to me. Running just Colonize Valyria alonside the main mod runs fine, but once I start using AGOT Overhaul I start getting the crashes. Someone earlier said running 2.5.2.2 shouldn't matter though, so I don't know.
Aszrayel
 
Posts: 53
Joined: Mon Apr 20, 2015 22:00

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by GoogleSearch » Wed Jun 29, 2016 21:15

I am also getting crashes with the exactly the same submods
User avatar
GoogleSearch
 
Posts: 300
Joined: Sat Jul 07, 2012 14:30

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Mazetism » Thu Jun 30, 2016 13:12

Aszrayel wrote:
Mazetism wrote:
GoTfanboy wrote:Did you keep colonize Valyria enabled, and only disable AGOT Overhaul? When you stopped getting crashes.

It sounds like you may not be using colonize Valyria.



Oh no, I'm using Colonize Valyria. I found this mod through Colonize Valyria.


Are you running AGOT 2.5.2.2 like I am? Same thing happens to me. Running just Colonize Valyria alonside the main mod runs fine, but once I start using AGOT Overhaul I start getting the crashes. Someone earlier said running 2.5.2.2 shouldn't matter though, so I don't know.


Ah, my game must have updated to 2.5.2.2 when I was cleaning stuff off steam because I was on 2.5.2 last week. Oh well, just gotta wait til this gets updated because I can go maybe a year and the game crashes showing me those same errors.

Edit: I think I came up with a quick fix because I tested this and have yet to come across a crash. It might work for you 2.5.2.2 guys but try deleting your retinue_subunits folder in the common folder. After deleting that folder, I haven't got a ctd.
User avatar
Mazetism
 
Posts: 3
Joined: Tue Jun 28, 2016 15:24

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by TalymTarg » Thu Jun 30, 2016 16:51

Ok, I have 2 questions.

Where is the code to delete to get rid of the dragon rider titles?

How can I remove the once in a lifetime restriction on the Dragon Invasion?
TalymTarg
 
Posts: 73
Joined: Mon Nov 23, 2015 20:46

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Draakje79 » Thu Jun 30, 2016 16:59

TalymTarg wrote:Ok, I have 2 questions.

Where is the code to delete to get rid of the dragon rider titles?

How can I remove the once in a lifetime restriction on the Dragon Invasion?


I been waiting for the dragon rider titles to be deleted in next update.

There is no reason to delete the dragon invasion casus belli as it is additional and different from the normal dragon conquest casus belli which still exists. Actually the dragon invasion is a smart addition I think.

My game also keeps crashing since I have been using the 2.5.2.2 version of the game so hopefully this will be fixed in next update too.
Draakje79
 
Posts: 23
Joined: Tue Aug 12, 2014 13:30

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by TalymTarg » Thu Jun 30, 2016 17:30

I want to remove the 1x a lifetime restriction. I think it is plenty realistic that a dragon rider would just burn people out of their lands instead of demanding fealty necessarily, gives me titles to make a Valyrian nation w/ and due to the requirement to actually siege entire counties, it slows down any OP it may have, in my opinion.

Just for my own gameplay interests, really.
TalymTarg
 
Posts: 73
Joined: Mon Nov 23, 2015 20:46

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Amr » Thu Jun 30, 2016 20:12

this mod keeps changing my flags
Amr
 
Posts: 8
Joined: Fri Aug 21, 2015 21:55

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Helvetti » Sat Jul 02, 2016 15:19

I don't see how 2.5.2.1/2 would crash the game, as they only changed the EU4 converter...
Image
User avatar
Helvetti
 
Posts: 65
Joined: Fri Jun 19, 2015 03:03

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by GoTfanboy » Sun Jul 03, 2016 03:35

I'm not sure either. I have yet to get a crash.

Has colonize valyria been updated? I'm running 6 June version.

I don't have my computer handy else I'd check.
“... a mind needs books as a sword needs a whetstone, if it is to keep its edge.”
User avatar
GoTfanboy
 
Posts: 88
Joined: Wed May 27, 2015 03:31

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Helvetti » Sun Jul 03, 2016 13:31

Yeah, another save and once again crashing in the same ~2 months max.
Image
User avatar
Helvetti
 
Posts: 65
Joined: Fri Jun 19, 2015 03:03

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Aszrayel » Sun Jul 03, 2016 18:10

GoTfanboy wrote:I'm not sure either. I have yet to get a crash.

Has colonize valyria been updated? I'm running 6 June version.

I don't have my computer handy else I'd check.


I don't think so. The date shown on dropbox, from accessing the download link in the Colonize Valyria thread, shows June 5, 2016. That's the version I used.
Aszrayel
 
Posts: 53
Joined: Mon Apr 20, 2015 22:00

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by GoTfanboy » Tue Jul 05, 2016 18:22

It is worth mentioning again. This mod requires a new game.

I'm at a loss for the flag changes and crashes. I've never had either issue.

I could upload the entirety of my mod folder (minus GOT) and see if that helps. I've been fixing little things, very minor updates.

I'll do that when I get home
“... a mind needs books as a sword needs a whetstone, if it is to keep its edge.”
User avatar
GoTfanboy
 
Posts: 88
Joined: Wed May 27, 2015 03:31

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by GoTfanboy » Tue Jul 05, 2016 18:25

Also, can you upload a save that crashes?
“... a mind needs books as a sword needs a whetstone, if it is to keep its edge.”
User avatar
GoTfanboy
 
Posts: 88
Joined: Wed May 27, 2015 03:31

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Aszrayel » Tue Jul 05, 2016 20:05

All of my attempts have been new games. I already deleted those saves, but will start up a new game sometime today and upload it. I can say the crashes consistently start a few years in. I usually play AFFC bookmark and they start occurring early 8302.

Edit: Here's a link to a saved game; crashes in early 8302 (around February/March) https://www.dropbox.com/s/qmgj2zvk80ko4t5/AGOT%20Overhaul%20Test%20January.ck2?dl=0
Aszrayel
 
Posts: 53
Joined: Mon Apr 20, 2015 22:00

Re: AGOT Overhaul v1.21 (w/ Valyrian Magic)

PostPosted by Kiddterra » Tue Jul 05, 2016 23:32

So does this mod work with 2.5.2.2 or not? I seem to get mixed messages from people.
Kiddterra
 
Posts: 12
Joined: Sat Jan 09, 2016 16:10

PreviousNext

Return to Sub-Mods

Who is online

Users browsing this forum: No registered users and 0 guests